Resolved
This issue has been resolved and shouldn't drain stock anymore.
Identified
The issue was caused by stock being deducted before result delivery. We are currently fixing it.
Identified
Searcher is currently deducting stock upon captcha completion instead of after a result delivery.